Uberspark staging

I seem to get an error when I don’t run uberspark staging create <platform> first after a new install. For example, I get an error if I run uberspark staging create rpi3 before uberspark staging create generic-platform, but do not generate any errors when running them in the opposite order.<\del>

For example, I get an error when I run uberspark uobjcoll build before running uberspark staging create that I don’t seem to be able to recover from without reinstalling uberspark. Running uberspark staging create after uberspark uobjcoll build results in the same error, and does not create the needed staging.

That is wierd!

Can you post the error output from the tool?

In attempting to recreate the error, I realized that I missed a critical step in arriving at this error condition (the OP was incorrect and has been edited).

  1. run uberspark uobjbuild --platform=rpi3 (for a specified platform before creating the staging)
  2. attempt to fix by running uberspark staging create rpi3
    This generates an error (that creating the generic-platform staging seems to not experience/clear)

The error message received is:

uberspark >> Loading current configuration...uberspark >> config_ns__json_path=/home/slab/uberspark/staging/rpi3/uberspark/config/uberspark.json
uberspark: internal error, uncaugh excewption:
Sys_error("/home/slab/uberspark/staging/rpi3/uberspark/config/uberspark.json: No such file or directory")
Raised by primitive operation at file "stdlib.ml", line 398, character 28-54
Called from file "stdlib.ml" (inlined), line 403, character 2-45
Called from file "lib/read.mli", line 1135, characters 13-25
Called from file "uberspark_manifest.ml", line 82, characters 16-50
Called from file "uberspark_config.ml", line 106, characters 24-84
Called from file "commoninit.ml" line 30, characters 9-35
Called from file "cmd_staging.ml", line 301, characters 19-24
Called from file "cmdlinear_term.ml" line 25, characters 19-24
Called from file "cmdlinear.ml" lin 26, characters 27-34
Called from file "cmdlinear.ml", line 117 characters 32-39

Note, this is the same error raised by both commands.

Reinstalling uberspark and running the commands in the proper order (staging create then uobjcoll build) removes the error condition.