überSpark: Conversion of existing hardware model to next-gen toolkit

Hoping to discuss the implementation of the next-gen hardware model, referencing discussions below:

Should we follow the same naming convention as the uobjrtls, something like uberspark_hwm__<HWMMODULEPATH>__<FNNAME>?

Thanks!

Hey Ethan,

Sorry for the delay in my response. Been out with back to back deadlines at work. I have created a new task and assigned it to you. See below:

I have also added some notes for the hardware model organization and how things should be laid out in general. Please take a look at the task and let us continue our discussion there.

Thanks!