TrustVisor uberapp installation


We have tried to install trustvisor on Ubuntu 12.04 with TPM 2.0. We have executed all the steps that are described in the documentation . After the installation and the building two files in /boot were created as expected, hypervisor-x86.bin.gz and init-x86.bin. Also we succesfully downgraded grub 2 to grub legacy. We installed all the required tools and packets(“aptitude” “pbuilder” “texinfo” “ruby” “build-essential” “autoconf” “libtool” “cbmc” “gcc-multilib” “jtss” “jtpmtools”) alonside with newlib-1.19.0.tar.gz and openssl-1.0.0d.tar.gz . I have some questions that I present below:

1.The hypervisor-x86.bin.gz neesd to be unziped first?

2.How we start the hypervisor from grub?We should do something like :
a.set root=(hd0,2)
b.linux /boot/hypervisor-x86.bin.gz root=/dev/sda2
c.initrd init-x86.bin

3.When we tried the above we get an error: “invalid magic number” in step b.

Thank you in advance.

Hi @SavvasR1991,

No, the image will be unzipped automatically by Grub.

Your grub entries are incorrect. Please take a look at the legacy uberXMHF installation instructions at:

1 Like